欢迎您访问 最编程 本站为您分享编程语言代码,编程技术文章!
您现在的位置是: 首页

HDU2317 下流黑客【水问题

最编程 2024-07-09 11:45:28
...


Nasty Hacks




Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


Total Submission(s): 2620    Accepted Submission(s): 2047



Problem Description


You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use


to fool their friends. The company has just finished their first product and it is time to sell it. You want to make as much money as possible and consider advertising in order to increase sales. You get an analyst to predict the expected revenue, both with and without advertising. You now want to make a decision as to whether you should advertise or not, given the expected revenues.



Input


The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: -106 ≤ r, e ≤ 106 and 0 ≤ c ≤ 106.


 


Output


Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or not, or whether it does not make any difference.


 


Sample Input


3


0 100 70


100 130 30


-100 -70 40


 


Sample Output


advertise


does not matter


do not advertise


 


Source


Nordic 2006


题目大意:公司销售商品的时候在考虑做不做广告,给你不做广告的预期效益、做广告的预期

效益和做广告的花销。为了效益问题,问:是否该做广告。做广告就输出"advertise",不做广

告就输出"do not advertise",做不做都一样就输出"does not matter"。

思路:计算不做广告的效益和左广告的效益-做广告的花销哪个高,然后根据情况输出不同结果。



#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
int T;
cin >> T;
while(T--)
{
int r,e,c;
cin >> r >> e >> c;
if(r > e - c)
cout << "do not advertise" << endl;
else if(r == e - c)
cout << "does not matter" << endl;
else
cout << "advertise" << endl;
}

return 0;
}